MENU CONTACT 
   Redirecting... ...to our OLD website!


We're still in the process of converting the site to the new format.

Apologies for the inconvenience and thank you for your understanding.

-Matt, Admin

5

Ok - go now to OLD site

No thanks - stay on NEW site


Technical Motorbike Help

Vulcan 500 indicator problem

Vulcan 500 indicator problem (1) - Forums [Biker Match] Vulcan 500 indicator problem (1) - Forums [Biker Match]
Home / Search Forums / Technical Motorbike Help /

Vulcan 500 indicator problem

 Posts: 5       Pages: 1/1

Post Reply
My Vulcan 500 ‘s right hand indicator flashes extremely fast front and back can any body help please?the hazards are not working is this indicative of the same fault?also how would I go about fixing this?Please help

   Update Reply
MalMac @ 06/06/2018 23:16  

Could be indercator relay or wrong bulb

   Update Reply
Paul1976 @ 06/06/2018 23:33  

Hello Good morning I'm Mary from Michigan nice meeting you I would like to hear back from you

   Update Reply
Deleted Member @ 07/06/2018 11:33  

Hi Paul thanks for the input would a dicky relay cause that on one side? ummmmh worth trying cheers mate I’ll let you know

   Update Reply
MalMac @ 08/06/2018 13:18  

Hi there malmac... have you changed any bulbs lately or fitted new indicators as the standard is 12volt 21 watt per bulb any lower on the wattage can cause that problem (some chinese units come fitted with 10 watt bulbs ) or non balanced led units that need an inline resistor or a solid state indicator unit fitting....

   Update Reply
nellie @ 10/06/2018 00:19  

 Posts: 5       Pages: 1/1

Back to top
Facebook Twitter Google Pinterest Text Email